
1 

http://www.tychina.pro/библиотека-задач-1/ 

O-01 (ANSYS) 
Формулировка задачи: 

Дано: E, a, q, l, ν=0,25 

Односвязная 

плоскопространственная рама 

постоянного поперечного 

сечения, наруженная 

распределённой силой. 

Найти: 1) Эпюру внутренних моментов; 

2) Вертикальное перемещение точки B: δB. 

Аналитический расчёт (см. O-01) даёт следующие решения: 

4

z 2,2I 5 a   - изгибный момент инерции поперечного сечения; 

4

y zI a I0,25 0,1111     - второй осевой момент инерции; 

4

ê zI 0,789 0,3 7a I50    - геометрическая жёсткость 

поперечного сечения при кручении; 
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Рис. 1. 

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 

 

 

 

q  

 , Н·м 

A 

B 

C 

О.С. №2 

M 
 

2 l  

a 

A 

C 

l  

E, Ix 3
·a

 

a=l/200 

 

 

A 

M 
 

a 

C 

β=0,263 

3
·a

 

y 

z 

http://www.tychina.pro/app/download/9910960993/O-01.pdf?t=1424280437


2 

http://www.tychina.pro/библиотека-задач-1/ 

Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

 

Чёрное рабочее поле не всегда 

приятно для глаза. Кроме того, оно 

неудобно для печати рисунков. 

Меняем чёрный цвет фона на белый 

следующими действиями: 

U_M > PlotCtrls > Style > Colors 

> Reverse Video 

 

Убрать пункты меню, относящиеся к 

расплавам, магнитам и так далее, оставить только 

относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 
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При построениях полезно видеть номера 

точек и линий твердотельной модели: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE ; 

Установить Elem на “No numbering”; 

Установить [/NUM] на “Colors & numbers” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» 

> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» 

> OK 

 

 

 

 

 

Предварительные настройки выполнены, можно приступать к решению 

задачи. 
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Решение задачи: 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1           > Accept > 

q=1           > Accept > 

l=1           > Accept > 

a=l/20         > Accept > 

Iz=1          > Accept > 

Iy=0.1111*Iz  > Accept > 

Ik=0.3507*Iz  > Accept > 

ASect=1e6     > Accept > 

nu=0.25       > Accept > 

> Close  

2 

Первая строчка в таблице конечных элементов – балочный тип BEAM44: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM44 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close  

3 

Реальные константы для элемента BEAM44: 

C_P > R,1,ASect,Iz,Iy,a,3*a,Ik >  

Посмотрим таблицу реальных констант: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Close 
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№ Действие Результат 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

В окошке EX пишем “E”, в окошке PRXY пишем “nu” 

> OK 

Закрываем окно «Deine Material Model Behavior». 
 

Твердотельное моделирование 

5 

Координаты узлов рамы: 

Определяемся с положением рамы относительно глобальной декартовой системы 

координат. 
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6 

Ключевые точки  A→1, B→2, C→3: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем   0,0, l       > Apply > 

NPT пишем 2 

X,Y,Z пишем 2*l,0,l      > Apply > 

NPT пишем 3 

X,Y,Z пишем 2*l,0,0  > OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

 - изометрия;   - автоформат. 
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№ Действие Результат 

7 

Оcи стержней рамы: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2 

2 и 3  

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

8 

Закрепления: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку 

> OK > 

Lab2 установить “UY”  

> Apply 

Левой кнопкой мыши нажать на 3 ключевую точку 

> OK > 

Lab2 установить “All DOF”  

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  
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№ Действие Результат 

Конечноэлементная модель 

9 

Указываем материал, тип элементов и номер поперечного сечения: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

[TYPE]   установить “1 BEAM44” 

[MAT]    установить “1” 

[REAL]   установить “1” 

> OK 
 

10 

Размер элементов: 

Линия L1 нагружена распределённой поперечной силой, её нужно разбить 

несколькими конечными элементами; линия L2 без распределённых нагрузок можно 

бить одним конечным элементом: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > Picked Lines > 

Левой кнопкой мыши кликаем на линию L1 

> OK 

NDIV пишем 20 

> Apply > 

Левой кнопкой мыши кликаем на линию L2 

> OK > 

NDIV пишем 1 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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11 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots  

Видим сразу две модели – твердотельную и конечноэлементную. 

 

12 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls >  

Появляется первое окно Multi-Plotting > OK > 

Появляется второе окно Multi-Plotting > 

Оставляем в нём отметки только напротив Nodes и Elements 

> OK 

Обновляем изображение:  U_M > Plot > Multi-Plots  
Теперь видим только конечноэлементную модель. 

 

13 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds > OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

14 

Проверяем ориентацию поперечного сечения: 

U_M > PlotCtrls > Style > Size and Shape > 

[/ESHAPE] установить отметку “on” > OK 

Корректируйте масштаб кнопками ,  или . 

Видно, что плоскость рамы параллельна меньшей стороне сечения, как и должно 

быть. Убираем прорисовку сечения: 

U_M > PlotCtrls > Style > Size and Shape > 

[/ESHAPE] убрать отметку, установив “off” > OK  

15 

Поперечная распределённая нагрузка ·q: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Pressure > On Beams > 

Левой кнопкой мыши отмечаем 20 элементов длинного стержня 

> Apply > 

LKEY пишем 2 

VALI пишем q 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots  

Расчёт 

16 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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№ Действие Результат 

Просмотр результатов: 

17 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as  устанавливаем  Arrows 

> OK > 

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK 

Обновляем изображение: U_M > Plot > Elements 

Получаем тот же результат, что и на рис. 1. 

В рабочем поле видим следующее: 

- Красным цветом начерчена распределённая внешняя сила; 

- Малиновым цветом нарисованы реактивные силы; 

- Фиолетовым начерчены векторы реактивных моментов: изгибного (поперёк оси 

короткого стержня) и крутильного (вдоль его оси). 
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№ Действие Результат 

18 

Вид сверху: 

 - вид сверху; 

  - автоформат (размер изображения по размеру окна рабочего поля). 

 

19 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

20 

Составление эпюры внутреннего изгибающего момента Mизг: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” 

> Apply >  

“By sequence num”, “SMISC,”, “12” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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№ Действие Результат 

21 

Прорисовка эпюры Mизг: 

M_M > General Postproc > Plot Results > Contour Plot > 

Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

Fact пишем 1 

> OK 

Получаем тот же результат, что и на рис. 1. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. А, вот, со знаками (“вверх” эпюра 

или “вниз”) осторожно! Быть уверенным здесь можно только в форме. 

Можете рисунок эпюры сделать крупнее: коэффициент Fact установите 2 или 3. 
 

22 

Составление эпюры внутреннего крутящего момента Mкр: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “4” 

> Apply >  

“By sequence num”, “SMISC,”, “10” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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№ Действие Результат 

23 

Прорисовка эпюры Mкр: 

M_M > General Postproc > Plot Results > Contour Plot > 

Line Elem Res > 

LabI установить “SMIS4” 

LabJ установить “SMIS10” 

Fact пишем 1 

> OK 

Получаем тот же результат, что и на рис. 1. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. В эпюрах крутящего момента, в 

отличие от изгибающего, можете быть уверенными и в знаках моментом тоже. С 

аналитическими расчётами знаки совпадают всегда. 

В данном случае видим: крутящий момент на длинном стержне нулевой, на 

коротком - положительный.  

24 

Выделяем узел в точке B: 

Узлы и элементы: 

U_M > Plot > Multi-Plots 

Выделяем узел в точке B (угловой узел): 

U_M > Select > Entities > 

Устанавливаем “Nodes” и “By Num/Pick” 

Селектор установить на “From Full” 

> OK 

Левой кнопкой мыши кликнуть на угловой узел. На панельке 

появляется номер узла. Видно, что это узел №2. 

> OK 
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№ Действие Результат 

25 

Вертикальное перемещение узла №2 ( точка B) 

M_M > General Postproc > List Results > 

> Nodal Solution > Nodal Solution > 

> DOF Solution > Y-Component of displacement > 

> OK 

Получаем методом конечных элементов: 

4

z
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что в точности совпадает с результатом аналитического расчёта (рис. 1.). 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 


