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Q-01 (ANSYS) 
Формулировка задачи: 

Дано: Консольный круглый стержень с фланцем нагружен внешним крутящим 

моментом M на конце и поперечной 

силой F на фланце.  
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Найти: 1) Эпюры Mкр  и Mизг ; 

2) Диаметр стержня d из условия прочности  max
экв  . 

Аналитический расчёт (см. Q-01) даёт следующие решения: 
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Рис. 1. 
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Рис. 2. 
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Максимальное эквивалентное напряжение реализуется в сечении  IV-IV : 

d 

σ
max

=232,9 МПа 

σ
min

=- σ
max

=-232,9 МПа 

 

σ 
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Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

 

Чёрное рабочее поле не всегда 

приятно для глаза. Кроме того, оно 

неудобно для печати рисунков. 

Меняем чёрный цвет фона на белый 

следующими действиями: 

U_M > PlotCtrls > Style > Colors 

> Reverse Video 

 

Убрать пункты меню, относящиеся к 

расплавам, магнитам и так далее, оставить только 

относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 
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При построениях полезно видеть 

номера узлов и номера конечных элементов 

(один участок – один конечный элемент): 

U_M > PlotCtrls > Numbering > 

Отметить NODE ; 

Установить Elem на “Element type num”; 

Установить [/NUM] на “Colors&numbers” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» 

> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» 

> OK 

 

 

 

 

 

Предварительные настройки выполнены, можно приступать к решению 

задачи. 
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Решение задачи: 

Размер d будем подбирать итерационно. В качестве первого приближения зададим ему, например, значение l. 

Модуль упругости первого рода материала и коэффициент Пуассона в статически определимых задачах ни на эпюру ни 

на напряжения не влияют. Зададим их равными среднестатистическим свойствам стали: E=2∙10
11

 Па и ν=0,3.  

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

l=0.2    > Accept > 

F=1e3    > Accept > 

M=F*l/2  > Accept > 

d=l      > Accept > 

E=2e11   > Accept > 

nu=0.3   > Accept > 

> Close 
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№ Действие Результат 

2 

Первая строчка в таблице конечных элементов – трёхмерный балочный BEAM188, 

вторая строчка – трёхмерный балочный абсолютно жёсткий BEAM188: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Add 

Element reference number пишем 1 

В левом окошке выбираем “Beam” 

В правом окошке “2 node 188” 

> OK > 

В окошке Element types отметить строчку “1 BEAM188” 

> Options > 

K3 установить “Quadradic Form” 

> OK > 

> Add > 

Element reference number пишем 2 

В левом окошке выбираем “Constraint” 

В правом окошке “Nonlinear MPC184” 

> OK > 

В окошке Element types отметить строчку “2 MPC184” 

> Options > 

K1 установить “Rigid Beam” 

> OK > 

K2 установить “Direct Elimination” 

> OK > 

> Close 
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№ Действие Результат 

3 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK 

Закрываем окно«Deine Material Model Behavior». 

 

Поперечное сечение 

4 

Круглое поперечное сечение диаметром d: 

M_M > Preprocessor > Sections > Beam > Common Sections 

ID пишем 1 

NAME пишем, например, Circle 

Sub-Type установить изображение круга 

R пишем d/2 (это радиус круга) 

N пишем, например, 36 (секторов) 

T пишем, например, 18 (колец) 

> OK 
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№ Действие Результат 

5 

Координаты узлов стержня и узлов фланца: 

Определяемся с положением точек относительно глобальной декартовой системы 

координат. Начало отсчёта поместим, например, в заделанный край стержня. 

 Y 

X 

Z 

B ( 0, 0, 4∙l ) 

C ( 0, l/2, 4∙l ) 

D ( 0, 0, 6∙l ) 

A ( 0, 0, 0 ) 

z 

y 

z 

y 

4∙l 

2∙l 

l/2 

 ① 

② 
 

Конечноэлементная модель 

6 

Проставляем узлы модели A→1, B→2, С→3 и D→4 : 

M_M> Preprocessor > Mоdeling > Create> Nodes > In Active CS > 

NPT пишем 1 

X,Y,Z пишем 0,0,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем 0,0,4∙l > Apply > 

NPT пишем 3 

X,Y,Z пишем 0,l/2,4∙l > Apply > 

NPT пишем 4 

X,Y,Z пишем 0,0,6∙l    > OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

Изометрия:   Автоформат:  
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№ Действие Результат 

7 

Один участок  – один конечный элемент. Протягиваем элементы по направлениям 

глобальных декартовых осей координат X, Y и Z: 

Устанавливаем свойства податливых элементов стержня: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Elem Attributes > 

[TYPE] установить “1 BEAM188” 

[MAT ] установить “1” 

[SECNUM] установить “1 Circle” 

> OK 

Протягиваем  элементы стержня: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes > 

Левой кнопкой мыши последовательно кликаем на узлы 

1, 2, 3 > Apply > 

2, 4, 3 > OK 

Устанавливаем свойства жёстких элементов фланца: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Elem Attributes >  

[TYPE] установить “2 MPC184” 

> OK 

Протягиваем  элемент фланца: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes > 

Левой кнопкой мыши последовательно кликаем на узлы 

2, 3 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
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№ Действие Результат 

8 

Проверяем ориентацию поперечного сечения на стержнях рамы: 

Прорисовка осей систем координат балочных конечных 

элементов: 

U_M > PlotCtrls > Symbols > 

ESYS ставим галочку On 

> OK 

Смотрим только на голубые элементы стержня: оси z (синяя 

чёрточка) и y (зелёная чёрточка) расположены так, как 

нужно, в соответствии с рис.1. 

 

9 

Закрепления: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Displacement > On Nodes > 

Левой кнопкой мыши нажать на узел 1 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

10 

Нагрузка: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши кликнуть на узел 3 

> OK > 

Lab установить “FX” 

VALUE установить “2*F” 

> Apply > 

Левой кнопкой мыши кликнуть на узел 4 

> OK > 

Lab установить “MZ” 

VALUE установить “M” 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

 

Расчёт 

11 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. 

Если появляется окно предупреждения Verify. На нём нажимаем YES.  

Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. Расчёт 

окончен. 
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№ Действие Результат 

Просмотр результатов 

12 

Форма упругой оси нагруженной рамы: 

M_M > General Postproc > Plot Results > Deformed Shape > 

KUND установить Def + undeformed > OK 

Некоторые символы пропадают. Восстановим их: 

U_M > PlotCtrls > Symbols > 

Boundary condition устанавливаем “All Applied BCs” 

> OK 

Форма стержня до нагружения (недеформированная) изображена сеткой чёрным 

цветом, форма после нагружения (деформированная) изображена цветными осями 

балочных конечных элементов.  

13 

Расчёт эпюр внутренних моментов: 

Внутренний крутящий момент Mкр: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “4”  > Apply >  

“By sequence num”, “SMISC,”, “17” > OK  

Внутренний изгибающий момент My: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “2”  > Apply >  

“By sequence num”, “SMISC,”, “15” > Apply > 

Внутренний изгибающий момент Mz: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “3”  > Apply >  

“By sequence num”, “SMISC,”, “16” > OK > 

> Close 
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№ Действие Результат 

14 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > 

> Uniform Contours > 

NCONT пишем 10 

> OK  

15 

Эпюры будем смотреть на недеформированной форме: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “0.0(off)” 

> OK 

 

16 

Эпюра внутреннего крутящего момента Mкр: 

Прорисовка эпюры Mкр: 
M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS4” 

LabJ установить “SMIS17” 

> OK  

Знаки и модули крутящих моментов на всех трёх стержнях совпадают с 

результатом аналитического расчёта (рис. 1.). Расположение частей эпюры 

необычно – отрицательная часть направлена вверх, положительная – вниз.  
 



14 

http://www.tychina.pro 

№ Действие Результат 

17 

К сожалению, эпюры изгибающих моментов ANSYS 

показывает не в плоскости действия момента, а в 

плоскости, перпендикулярной взгляду наблюдателя.  

Для того, чтобы корректно просматривать эпюру 

внутреннего изгибающего элемента, нужно на сам элемент 

смотреть с острия оси изгиба. Определимся с ракурсами 

просмотра эпюр: 

 

Y 

X 

Z 

z 

y 

z 

y 

 

 

 

  

 

Рис.3. 
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№ Действие Результат 

18 

Эпюра внутреннего изгибающего момента My: 

Вид справа:  

Прорисовка эпюры My: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS2” 

LabJ установить “SMIS15” 

> OK 

Изометрия:  

Кажется, что эпюра имеет вид прямоугольника. На самом деле, вглядитесь в 

цветовую шкалу, значения на эпюре практически нулевые, ошибки округлений, не 

более того. Эпюра My и должна быть нулевой, на рис.1. она даже не показана. 
 

19 

Эпюра внутреннего изгибающего момента Mz: 

Вид сверху:  

Прорисовка эпюры Mz: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS3” 

LabJ установить “SMIS16” 

> OK 

Изометрия:  

Результат полнстью совпадает с аналитической эпюрой на рис.1.  
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№ Действие Результат 

20 

Отмена прорисовки осей систем координат элементов: 

Прорисовываем элементы: 

U_M > Plot > Elements 

Отмена прорисовки осей: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем на All Applied BCs 

ESYS убираем галочку Off 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
 

21 

Эквивалентные напряжения (теория максимального касательного напряжения 

Треска – Сен-Венана): 

Прорисовываем элементы полноразмерно: 

U_M > PlotCtrls > Style > Size and Shape > 

[/ESHAPE] установить галочку “On” 

> OK 

Эквивалентные напряжения: 

M_M > General Postproc > Plot Results > 

> Contour Plot > Element Solu> 

> Element Solution> Stress> Stress intensity 

> OK 

Видим: при d=l=0,2 м напряжение 
max
экв 2,04 МПа .    
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№ Действие Результат 

22 

Первая итерация (подбираем значение d): 

Во сколько раз полученное максимальное напряжение меньше желаемого? 

 

max 6
экв 4

6

2,04 10
87,44 10 .

233,3 10







   


 

Новое значение d: 

43 3
новое староеd d 0,2 87,44 10 0,2 0,206 0,04120 м .          

Меняем значение параметра d: 

U_M > Parameters > Scalar Parameters > 

d=0.0412 > Accept > 

> Close 

Новый размер сечения в соответствии с новым  d: 

M_M > Preprocessor > Sections > Beam > Common Sections 

R пишем d/2 

> OK 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS > OK > YES > Close 

Эквивалентные напряжения: 

M_M>General Postproc>Plot Results>Contour Plot> Element Solu> 

> Element Solution> Stress> Stress intensity 

> OK 

Видим: при d=l=0,0412 м, максимальное значение эквивалентного напряжения на 

цветовой шкале отображено до трёх значащих цифр 
max 6
экв 233 10 Па   . Трёх 

значащих цифр нам мало. Нужный результат 233,3 задан четырьмя. 
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№ Действие Результат 

23 

Уточнение значения максимального эквивалентного напряжения: 

M_M > General Postproc > List Results > Element Solution > 

> Element Solution > Stress> Stress intensity > 

> OK 

Среди напряжений в поперечном сечении первого конечного элемента в узле №1 

(ELEMENT =1  ELEMENT NODE = 1) видим значение максимального 

эквивалентного напряжения с точностью до пяти значащих цифр. Округляем до 

четырёх – с такой точностью мы ведём расчёт в курсе «Сопротивление 

материалов»: 

max 6
экв 233,5 10 Па   . 
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№ Действие Результат 

24 

Вторая итерация (подбираем значение d): 

 

max 6
экв

6

3 3
новое старое

233,5 10
1,001 ;

233,3 10

d d 0,0412 1,001 0,04121 м .









  



    

 

Меняем значение параметра d: 

U_M > Parameters > Scalar Parameters > 

d=0.04121 > Accept 

> Close 

Новый размер сечения в соответствии с новым  d: 

M_M > Preprocessor > Sections > Beam > Common Sections 

R пишем d/2 

> OK 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS > OK > YES > Close 

Эквивалентные напряжения: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Element Solu > Element Solution > Stress> Stress intensity 

> OK 
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№ Действие Результат 

25 

Уточнение значения максимального эквивалентного напряжения: 

M_M > General Postproc > List Results > Element Solution > 

> Element Solution > Stress> Stress intensity > 

> OK 

Среди напряжений в поперечном сечении первого конечного элемента в узле №1 

(ELEMENT =1  ELEMENT NODE = 1) видим значение максимального 

эквивалентного напряжения с точностью до пяти значащих цифр. Округляем до 

четырёх: 

max 6
экв 233,3 10 Па   . 

Поскольку желаемый результат достигнут (  max
экв  ) уточнять значение 

параметра d далее не будем, принимаем  

d=0,04121 м 

что в точности совпадает с результатом аналитического расчёта (рис.1.). 

Следует обратить внимание на то, что реализуется максимальное эквивалентное 

напряжение в узле №1 модели – в прикорневом поперечном сечении стержня. Это 

также соответствует результату аналитического расчёта (сечение  IV-IV , рис.1., 

рис.2.).  
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Геометрические характеристики круглого профиля при найденном значении 

диаметра d: 

M_M  > Preprocessor > Sections > Beam > Plot Section 

[Secplot] установить “1 Circle” 

Show section mesh? установить “Yes” 

> OK 

 

Видим: 

8 4
y

8 4
к

I 14,2 10 м ;

I 28,3 10 м ;





 

 

 

Эти численные значения с точностью до трёх значащих цифр 

практически не отличаются от своих аналитических аналогов (рис. 2.). 

 

Iизг= 

Iк= 
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Сечение IV-IV, эквивалентные напряжения σэкв: 

Прорисовываем элементы: 

U_M > Plot > Elements 

Вид сзади:  (рис.3.) Автоформат:  

Эквивалентные напряжения: 

M_M > General Postproc > Plot Results > 

> Contour Plot > Element Solu> 

> Element Solution> Stress> Stress intensity 

> OK 

Видим, что максимальные значения эквивалентного напряжения реализуются в точках 1 и 

2 поперечного сечения (рис. 2.), так же, как и при аналитическом расчёте. 

 max 6
экв 233,3 10 Па .     
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Сечение IV-IV, осевые нормальные напряжения σ: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Element Solu > Element Solution > Stress > 

> X-Component of stress 

> OK 

Равенство цветных полос по высоте (можете померить линейкой прямо на экране) 

говорит о линейном изменении осевых напряжений по высоте сечения. То же самое 

показывает рис.2. 

Минимальное MN и максимальное MX напряжения – экстремальные значения 

суммы осевых напряжений от изгиба и растяжения (или сжатия). Стержень не 

растягивается и не сжимается, значит перед нами – изгибные напряжения в чистом 

виде: 

min 6

max 6

MN 233 10 Па ;

MX 233 10 Па .





   

  

 

С точностью до трёх значащих цифр, изгибные напряжения практически такие же, 

как в аналитическом расчёте (рис.2.). 

На сечение смотрим против оси x элемента («сзади»), 

поэтому видим инверсные цвета. 

 

σ
max

 σ
min
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Сечение IV-IV, касательные напряжения от кручения τ: 

К сожалению, посмотреть целиком цветовую диаграмму касательных напряжений 

от кручения в сечении элемента BEAM188 невозможно, только диаграммы 

проекций векторов этих касательных напряжений на ось y и ось z элемента (рис.2.) 

соответственно. 

Прорисуем эти проекции и сравним значения напряжений в тех точках, где 

проекция вектора касательного напряжения на соответствующую ось составляет 

100% от его длины. 

Проекции векторов касательных напряжений на ось  y  элемента: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Element Solu > Element Solution > Stress > XY Shear stress 

> OK 

Полностью параллельны оси  y  вектора напряжений в верхней и нижней точках 

сечения (рис.2.). 

Проекции векторов касательных напряжений на ось  z  элемента: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Element Solu > Element Solution > Stress > XZ Shear stress 

> OK 

Полностью параллельны оси  z  вектора напряжений в точках 1 и 2 сечения (рис.2.). 

Все четыре упомянутые точки лежат на внешнем контуре круглого поперечного 

сечения и касательное напряжение в них различно по направлению, но одинаково 

по модулю – аналитический расчёт показывает τ
max

=7,278 МПа (рис.2.). ANSYS нам 

во всех четырёх точках показывает численное значение τ
max

=7,28 МПа – то же 

самое с точностью до трёх значащих цифр. 

На сечение смотрим против оси x элемента («сзади»), 

поэтому видим инверсные цвета. 

 

 

y 

z 

τ
max

 

τ
max

 

τ
max

 

τ
max

 

y 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 

 

 


