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Q-03 (ANSYS) 
Формулировка задачи: 

Дано: l , q  . 

Пространственная рама 

выполнена из трёх прямых 

стержней; нагружена 

распределённой силой q на 

последнем участке. 

Требуется: 

Построить  эпюру M 

внутренних изгибающих и 

крутящих моментов в 

стержнях рамы. 

Аналитический расчёт (см. Q-03) даёт следующую эпюру (в предположении, 

что главные центральные оси y и z поперечных сечений стержней рамы 

ориентированы по вертикали, по горизонтали или фронтально): 

 

C ( l, 0, l ) 

D ( l , -l , l ) 
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перемещение узла C: 

S ( 3∙l/2, -l, l ) 
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Задача данного примера: при помощи ANSYS Multyphisics получить эту 

же эпюру методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Убрать пункты меню, не относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать точки и линии твердотельной модели, узлы и элементы 

модели конечноэлементной: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, NODE, установить Elem на “No numbering”, 

установить [/NUM] на “Colors & numbers” > OK 

Увеличить размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи:  Приравняв q и l к единице, результаты получим в виде коэффициентов перед формулами. Площадь A 

поперечного сечения задаём большой, дабы вклад в перемещения вносил только изгиб. Значения изгибных 

моментов инерции Iy, Iz и крутильной жёсткости Iк на эпюру не влияют.  

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

q=1      > Accept > 

l=1      > Accept > 

A=1e6    > Accept > 

Iy=1     > Accept > 

Iz=1     > Accept > 

Ik=1     > Accept > 

E=1      > Accept > 

nu=0.25  > Accept > 

> Close 
 

2 

Первая и единственная строчка в таблице конечных элементов – трёхмерный 

балочный BEAM44: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM44 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 
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№ Действие Результат 

3 

Первая и единственная строчка в таблице наборов реальных констант :площадь 

поперечного сечения = A; моменты инерции = Iz и Iy; высота сечения от осей 

изгиба = zmax и ymax; и геометрическая жёсткость при кручении = Ik: 

C_P > R,1,A,Iz,Iy,l/100,l/100,Ik >  

Посмотрим таблицу реальных констант: 

M_M> Preprocessor > Real Constants > Add/Edit/Delete > Close 

 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK 

Закрываем окно «Deine Material Model Behavior». 
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№ Действие Результат 

Твердотельная модель 

5 

Координаты ключевых точек твердотельной модели рамы: 

Определяемся с положением точек рамы относительно глобальной декартовой 

системы координат. Начало отсчёта поместим, например, в заделке рамы. 

A, B, C и D – точки конструктивные; 

B, A и C – также служат, как ориентационные для участков ①, ② и ③ 

соответственно. Вместе с начальной и конечной точками соответствующего 

участка, ориентационная точка задаёт полулоскость, в которой лежат главные 

центральные оси z поперечных сечений его балочных конечных элементов.  
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6 

Проставляем точки твердотельной модели A→1, B→2, С→3 и D→4: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем -l,l,2*l 

> Apply > 

NPT пишем 2 

X,Y,Z пишем 0,l,2*l 

> Apply > 

NPT пишем 3 

X,Y,Z пишем 0,0,2* l 

> Apply > 

NPT пишем 4 

X,Y,Z пишем 0,0,0 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

Изометрия:   Автоформат:  
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№ Действие Результат 

7 

Линии участков ①, ② и ③ протягиваем по направлениям осей X, Y и Z: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

> Straight Line >  

Левой кнопкой мыши последовательно кликаем на точки 

1, 2 > Apply > 

3, 2 > Apply > 

4, 3 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
 

Конечноэлементная модель 

8 

Аттрибуты разбиения: 

M_M> Preprocessor > Meshing > Mesh Attributes > Picked Lines> 

Левой кнопкой мыши кликнуть на линию L1 

> OK > 

MAT установить “1” 

REAL установить “1” 

TYPE установить “1 BEAM44” 

Pick Orientation Keypoint(s) ставим галочку “Yes” 

> OK > 

Кликнуть на точку 3 – ориентационную для линии L1 

> Apply > 

Кликнуть на линию L2 

> OK > OK > 

Кликнуть на точку 1 – ориентационную для линии L2 

> Apply > 

Кликнуть на линию L3 

> OK > OK > 

Кликнуть на точку 2 – ориентационную для линии L3 

> OK 
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№ Действие Результат 

9 

Участок c распределённой нагрузкой нужно бить несколькими балочными 

конечными элементами, для участков без распределённой нагрузки хватит одного 

элемента: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

> Lines > Picked Lines> 

Левой кнопкой мыши кликаем на линию L1 

> OK >  

NDIV пишем 10 

> Apply > 

Левой кнопкой мыши кликаем на линии L2 и L3 

> OK >  

NDIV пишем 1 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

 

10 

Рабиваем линию на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All > 

> OK >  

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Видим сразу две модели – твердотельную и построенную по ней 

конечноэлементную. Рисунок неудобочитаем. 
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№ Действие Результат 

11 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls… >  

Появляется первое окно Multi-Plotting 

> OK > 

Появляется второе окно Multi-Plotting, оставляем в нём 

отметки только напротив Nodes и Elements 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

Читабельность рисунка улучшилась, однако ориентационный узел для участка ② 

и ориентационный узел для участка ③ “портят” масштаб. Масштаб подстраиваем 

кнопками вспомогательной панели справа            . 

Обновляем изображение:  U_M > Plot > Replot 
 

12 

Закрепления: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Displacement > On Nodes > 

Левой кнопкой мыши нажать на узел 24 в начале координат 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

13 

Проверяем ориентацию поперечного сечения на стержнях рамы: 

Прорисовка осей систем координат балочных конечных 

элементов: 

U_M > PlotCtrls > Symbols > 

ESYS ставим галочку On 

> OK 

Оси z (синяя чёрточка) и y (зелёная чёрточка) 

расположены так, как нужно, в соответствии с рис.1. 

 

14 

Поперечная распределённая нагрузка q: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Pressure > On Beams > 

Левой кнопкой мыши отмечаем десять элементов первого участка 

> Apply > 

LKEY пишем 1 

VALI пишем -q 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

15 

Сосредоточеннная сила: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши кликнуть на узел 22 

> OK > 

Lab установить “FX” 

VALUE установить “-q*l” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

Расчёт 

16 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. Расчёт 

окончен. 
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№ Действие Результат 

Просмотр результатов: 

17 

Форма упругой оси нагруженной рамы: 

M_M > General Postproc > Plot Results > Deformed Shape > 

KUND установить Def + undeformed > OK 

Некоторые символы пропадают. Восстановим их: 

U_M > PlotCtrls > Symbols > 

Boundary condition устанавливаем “All Applied BCs” 

[/PSF]устанавливаем “Pressures” 

> OK 

Форма стержня до нагружения (недеформированная) изображена сеткой чёрным 

цветом, форма после нагружения (деформированная) изображена синей линией. 

Чем большим количеством конечных элементов разбит участок, тем точнее 

прорисовывается форма его изогнутой оси. Участок ③ разбит одним элементом, 

поэтому кажется, будто в заделке он повернулся. 

В целом, деформированная форма упругой оси именно такая, какая и должна быть, 

исходя из жизненных наблюдений. 
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№ Действие Результат 

18 

Расчёт эпюр внутренних моментов: 

Внутренний крутящий момент Mкр: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “4” 

> Apply >  

“By sequence num”, “SMISC,”, “10” 

> OK  

Внутренний изгибающий момент My: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “5” 

> Apply >  

“By sequence num”, “SMISC,”, “11” 

> Apply > 

Внутренний изгибающий момент Mz: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” 

> Apply >  

“By sequence num”, “SMISC,”, “12” 

> OK > 

> Close 

 

19 

Эпюры будем смотреть на недеформированной форме: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “0.0(off)” 

> OK 
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№ Действие Результат 

20 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

Эпюру внутреннего крутящего момента на всей раме: 

21 

Эпюра внутреннего крутящего момента Mкр сразу на всей раме: 

Прорисовка эпюры Mкр: 
M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS4” 

LabJ установить “SMIS10” 

Fact пишем 1 

> OK  

Распечатка эпюры Mкр: 
M_M > General Postproc > List Results > 

> Elem Table Data > Line Elem Res > 

В списке отмечаем “SMIS4” и “SMIS10” 

> OK  

На всех элементах кроме последнего (соответствующего участку 

③) внутренний крутящий момент практически равен нулю. На 

последнем элементе внутренний крутящий момент равен +0,5 , 

как и должно быть в соответствии с рис. 1. 
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№ Действие Результат 

Эпюры внутренних изгибающих моментов рисуем поэлементно: 

22 

К сожалению, эпюры изгибающих 

моментов ANSYS показывает не в 

плоскости действия момента, а в 

плоскости, перпендикулярной взгляду 

наблюдателя.  

Для того, чтобы корректно 

просматривать эпюру внутреннего 

изгибающего элемента, нужно на сам 

элемент смотреть с острия оси изгиба. 

Определимся с ракурсами просмотра 

эпюр: 
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№ Действие Результат 

23 

Эпюра внутреннего изгибающего момента My на участке ①: 

Выделяем балочные конечные элементы участка (10 штук): 

U_P > Select > Entites 

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Последовательно кликаем левой кнопкой мыши на 

каждый из днсяти элементов участка 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Фронтальный вид :  

Прорисовка эпюры My: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS5” 

LabJ установить “SMIS11” 

> OK 

Изометрия:  

Видим параболический треугольник, направленный вниз, высотой 0,5. 

Это соответствует эпюре My на участке ① ( рис.1.). 
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№ Действие Результат 

24 

Эпюра внутреннего изгибающего момента Mz на том же элементе ①: 

Вид снизу:  

Прорисовка эпюры Mz: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

> OK 

Изометрия:  

То, что мы видим – ошибки округления. В этом легко убедиться, посмотрев на 

цветовую шкалу: все значения ничтожно малы. Рис.1. так и показывает – Mz равен 

нулю по всей длине участка ①. 
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№ Действие Результат 

25 

Эпюра внутреннего изгибающего момента My на участке ②: 

Выделяем и прорисовываем все элементы: 

U_P > Select > Everything 

U_P > Plot > Elements 

Выделяем балочный конечный элемент участка: 

U_P > Select > Entites 

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на вертикальный элемент 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Вид сзади:  

Прорисовка эпюры My: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS5” 

LabJ установить “SMIS11” 

> OK 

Изометрия:  

Прямоугольник влево, высотой 0,5. Так и должно быть в соответствии с рис.1. 
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№ Действие Результат 

26 

Эпюра внутреннего изгибающего момента Mz на том же элементе ②: 

Вид слева:  

Прорисовка эпюры Mz: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

> OK 

Изометрия:  

Вроде бы треугольник, но вглядитесь в его размеры – фактически и это тоже нуль. 

Рис.1. показывает то же самое.  
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№ Действие Результат 

27 

Эпюра внутреннего изгибающего момента My на элементе ③: 

Выделяем и прорисовываем все элементы: 

U_P > Select > Everything 

U_P > Plot > Elements 

Выделяем балочный конечный элемент участка: 

U_P > Select > Entites 

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на длинный элемент 

> OK 

Вид справа:  

Прорисовка эпюры My: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS5” 

LabJ установить “SMIS11” 

> OK 

Изометрия:  

Треугольник вниз высотой 2. На рис.1. то же самое. 
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№ Действие Результат 

28 

Эпюра внутреннего изгибающего момента Mz на элементе ③: 

Вид сверху:  

Прорисовка эпюры Mz: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

> OK 

Изометрия:  
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 

 

 


