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E-06 (ANSYS) 

Формулировка задачи: 

Дано: G, l, H, Δ, 
4G d

M
16 H l

   


 
; 

Упругий стержень нагружен 

сосредоточенным внешним 

крутящим моментом M. Точка С 

может поворачиваться не более, 

чем на угол φ0 . 

Найти: эпюры  Mкр , τmax, φ. 

Аналитический расчёт (см. E-06) даёт следующие решения: 
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Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

решения методом конечных элементов. 
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G – модуль сдвига 

материала стержня. 

http://www.tychina.pro/app/download/7942273393/E-06.pdf
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Скрываем пункты меню, не относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера узлов и номера конечных 

элементов (один участок – один конечный элемент): 

U_M > PlotCtrls > Numbering > 

Отметить NODE ; 

Установить Elem на “Element numbers”; 

Установить [/NUM] на “Colors&numbers” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: Приравняв G, d, Δ, H, l и M к единице, результаты получим в виде чисел, обозначенных на рис.1. синим 

цветом. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=2.6                      > Accept > 

nu=0.3                     > Accept > 

G=E/(2*(1+nu))             > Accept > 

PI=acos(-1)                > Accept > 

d=1                        > Accept > 

Delta=1                    > Accept > 

H=1                        > Accept > 

l=1                        > Accept > 

M= G*pi*D**4*Delta/(16*H*l) > Accept > 

> Close 

При E=2,6 и ν=0,3 имеем: 
 
E 2,6

G 1
2 1 2,6

  
 

. 
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№ Действие Результат 

2 

Таблица элементов: 1 – трёхмерный балочный BEAM188; 2 – жёсткий балочный 

MPC184; 3– контактный элемент CONTA178. 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Add 

Element reference number пишем 1 

В левом окошке выбираем “Beam” 

В правом окошке “2 node 188” 

> OK > 

В окошке Element types отметить строчку “1 BEAM188” 

> Options > 

K3 установить “Quadradic Form” 

> OK > 

> Add > 

Element reference number пишем 2 

В левом окошке выбираем “Constraint” 

В правом окошке “Nonlinear MPC 184” 

> OK > 

В окошке Element types отметить строчку “2 MPC184” 

> Options > 

K1 установить “Rigid Beam” 

> OK > OK > 

> Add > 

Element reference number пишем 3 

В левом окошке выбираем “Contact” 

В правом окошке “nd-to-nd 178” 

> OK > 

В окошке Element types отметить строчку “2 CONTA178” 

> Options > 

K2 установить “Penalty method” 

K4 установить “Real const GAP” 

K5 установить “Nodal coor - Z” 

> OK > Close 
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№ Действие Результат 

3 

Таблица реальных констант: 

Жёсткость контакта и величина зазора: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Add 

В окошке Element Type for Real Constants выбрать CONTA178 

> OK > 

В поле FKN пишем 1e3 

В поле GAP пишем Delta 

> OK 

Видим результат – один набор реальных констант в таблице Real Constants.  

> Close 
 

4 

Два поперечных сечения: 

Сечение S1 диаметром d: 

M_M > Preprocessor > Sections > Beam > Common Sections 
ID пишем 1 

NAME пишем имя сечения S1 

Sub-Type установить изображение круга 

Offset To установить “Centroid” 

R пишем d/2   (это радиус круга) 

N пишем, например, 36 (секторов) 

T пишем, например, 10 (колец   ) 

> OK 

Прорисовываем оба сечения, смотрим геометрическую жёсткость при кручении у 

сечения S1: 

M_M > Preprocessor > Sections > Beam > Plot Section 

[Secplot] установить “1 S1” 

Show section mesh? установить “Yes” 

> OK 

Значение 
4

кI 0,09817 d  совпадает с вычисленным аналитически (рис. 1а.). 

 

 

кI   
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№ Действие Результат 

5 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK 

Закрываем окно«Deine Material Model Behavior». 

 

6 

Координаты точек конструкции: 

Определяемся с положением точек относительно 

глобальной декартовой системы координат. Начало 

отсчёта поместим, например, в заделке. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Рис. 2. 
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№ Действие Результат 

Конечноэлементная модель 

7 

Узлы 1, 2, 3, 4, 5, 6 и 7 в точках A, B, C, D, K, N и R соответственно: 

Изометрия:  или       потом     . 

Проставляем узлы: 

M_M> Preprocessor> Mоdeling> Create> Nodes> In Active CS > 

NODE пишем 1  

X,Y,Z пишем 0,0,0 > Apply > 

NODE пишем 2 

X,Y,Z пишем l,0,0 > Apply > 

NODE пишем 3 

X,Y,Z пишем 2*l,0,0 > Apply > 

NODE пишем 4  

X,Y,Z пишем 2*l,H,0 > Apply > 

NODE пишем 5 

X,Y,Z пишем 2*l,H,-Delta > Apply > 

NODE пишем 6 

X,Y,Z пишем 2*l,-H,0 > Apply > 

NODE пишем 7 

X,Y,Z пишем 2*l,-H,Delta > OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

8 

Конечные элементы – участки стержня: 

Первый и второй элементы - балочные сечением S1: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Elem Attributes > 

[TYPE]установить “1 BEAM188” 

[MAT ]установить “1” 

[SECNUM]установить “1 S1” 

> OK 

Протягиваем элементы по направлению оси X: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

1 и 2 > Apply > 

2 и 3 > OK 

 

9 

Конечные элементы – жёсткие лепестки в точке C: 

Третий и четвёртый элементы – абсолютно жёсткие стерженьки: 

M_M> Preprocessor> Mоdeling > Create > Elements > 

> Elem Attributes > 

[TYPE]установить “2 MPC184” 

> OK 

Протягиваем элементы в любом направлении: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

3 и 4 > Apply > 

3 и 6 

> OK 
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№ Действие Результат 

10 

Контактные конечные элементы между лепестками и упорами: 

Пятый и шестой элементы – контактные «узел-в-узел»: 

M_M> Preprocessor> Mоdeling > Create > Elements > 

> Elem Attributes > 

[TYPE]установить “3 CONTA178” 

> OK 

Протягиваем элементы по направлению оси Z: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

5 и 4 > Apply > 

6 и 7 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

 

11 

Проверяем правильность формирования модели: 

Нумеруем элементы по их типу: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Element type num”; 

> OK 

Возвращаемся к порядковой нумерации элементов: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Element numbers”; 

> OK 
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№ Действие Результат 

12 

Заделки: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

> Structural > Displacement > On Nodes > 

Левой кнопкой мыши нажать на 1, 5 и 7 узлы 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 
U_M > Plot > Multi-Plots 

 

13 

Внешний момент: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Force/Moment > On nodes > 

Левой кнопкой мыши нажимаем на узел 2 

> OK > 

Lab установить “MX” 

VALUE пишем -M 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

14 

Скрываем оси системы координат: 

U_M > PlotCtrls > Window Controls > Window Options> 

[/Triad] установить “Not Shown” 

> OK 

 

Расчёт 

15 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK.  

На предупреждающих окнах “Verify” нажимаем OK. 

Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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№ Действие Результат 

Просмотр результатов 

16 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

> OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение: U_M > Plot > Elements 

В рабочем поле видим следующее: 

- Синим цветом начерчен внешний момент; 

- Фиолетовым цветом начерчен реактивный момент;  

- Малиновым цветом начерчены реактивные силы на упорах.  

Реакции совпадают с результатами аналитического расчёта, показанными на рис. 

1б. (числа, выделенные синим цветом). Минус означает направление вектора 

против соответствующей координатной оси X. 
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№ Действие Результат 

17 

Деформированная форма конструкции: 

Масштаб устанавливаем 1:1: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “1.0 (true scale)” 

> OK  

Прорисовываем совместно недеформированную (чёрным цветом) и 

деформированную (цветную) : 

M_M > General Postproc > Plot Results > 

> Deformed Shape > 

KUND установить Def + undeformed 

> OK  

Чёным цветом начерчена недеформированная форма конструкции, цветными 

линиями – консрукция после нагружения.  

 

18 

Составление эпюры эпюры внутреннего крутящего момента Mкр: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “4” 

> Apply > 

“By sequence num”, “SMISC,”, “17” 

> OK > 

> Close 
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№ Действие Результат 

19 

Прорисовка эпюры внутреннего крутящего момента Mкр: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res> 

LabI установить “SMIS4” 

LabJ установить “SMIS17” 

> OK  

Пропечатка эпюры внутреннего крутящего момента Mкр: 

M_M > General Postproc > List Results > Elem Table Data > 

Отметить мышью строчку SMIS4  

> OK  

Получаем тот же результат, что и на рис. 1в. (числа, выделенные синим цветом). 
 

20 

Полноразмерная отрисовка конечных элементов: 

Прорисовываем элементы: U_M > Plot > Elements 

Отрисовываем элементы полноразмерно, по их поперечным сечениям: 

U_M > PlotCtrls > Style > Size and Shape >  

[/ESHAPE] ставим галочку “on” 

> OK 

 

21 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 > OK 
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№ Действие Результат 

22 

Касательные напряжения: 

Перемещения не отображать: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “0.0 (off)” 

Раскрасить элементы по величине первого главного напряжения 

 (при чистом сдвиге оно равно касательному напряжению): 

M_M > General Postproc > Plot Results > 

> Contour Plot > Element Solu > 

> Element Solution > Stress > 

> 1st Principial stress > OK 

 

23 

Конечный элемент №1: 

Прорисовываем: U_M > Plot > Replot 

Выделяем нужный конечный элемент: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на элемент у заделки 

> OK 

Прорисовываем: U_M > Plot > Replot 

Видим, как касательные напряжения линейно увеличиваются от центра сечения к 

его краю. На краю max 0,75   , что идентично результатам аналитического 

расчёта, показанным на рис. 1г. (числа, выделенные синим цветом). 

Выделяем всё, что есть: U_M > Select > Everything 
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№ Действие Результат 

24 

Конечный элемент №2: 

Прорисовываем: U_M > Plot > Replot 

Выделяем нужный конечный элемент: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на элемент у лепестков 

> OK 

Прорисовываем: U_M > Plot > Replot 

На краю max 0,25   , что идентично результатам аналитического расчёта, 

показанным на рис. 1г. (числа, выделенные синим цветом). 

Выделяем всё, что есть: U_M > Select > Everything 
 

25 

Вновь изображаем элементы их осями: 

U_M > Plot > Elements  

U_M > PlotCtrls > Style > Size and Shape >  

[/ESHAPE] убираем галочку “off” 

> OK 
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№ Действие Результат 

26 

Угловые перемещения узлов (таблица): 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > X-Component of rotation > OK 

 

Получаем окно “PRNSOL Command” с табличкой, где NODE – номер узла 

конечноэлементной модели, а ROTX – его вращение относительно оси X: 

1 A 0    ; 

B2 H
1,5


      (точное совпадение с рис.1д.); 

3 C 1
H


     (точное совпадение с рис.1д.); 

 



18 

http://www.tychina.pro 

Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются файлы с 

расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, “.mntr”,  “.rst” и 

”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 

 

 

 

 

 


