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B-02 (ANSYS) 

Формулировка задачи: 

Дано: Cтержень между двумя заделками 

нагружен осевой силой. 

E – модуль упругости материала; 

A – площадь поперечного сечения. 

Найти: эпюры N , σ , ε , w. 

Аналитический расчёт (см. B-02) даёт следующие решения: 
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Рис. 1. 
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Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

решения методом конечных элементов. 
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http://www.tychina.pro/app/download/7945262393/B-02.pdf
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

 

Чёрное рабочее поле не всегда 

приятно для глаза. Кроме того, оно 

неудобно для печати рисунков. 

Меняем чёрный цвет фона на белый 

следующими действиями: 

U_M > PlotCtrls > Style > Colors 

> Reverse Video 

 

Убрать пункты меню, относящиеся к 

расплавам, магнитам и так далее, оставить только 

относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 
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При построениях полезно видеть 

номера узлов и номера конечных элементов 

(один участок – один конечный элемент): 

U_M > PlotCtrls > Numbering > 

Отметить NODE ; 

Установить Elem на “Element numbers”; 

Установить [/NUM] на “Colors&numbers” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» 

> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» 

> OK 

 

 

 

 

 

Предварительные настройки выполнены, можно приступать к решению 

задачи. 
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Решение задачи:  Приравняв E, A, F и l, к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом.  

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1    > Accept > 

A=1    > Accept > 

Iz=1e6 > Accept > 

F=1    > Accept > 

l=1    > Accept > 

nu=0.3 > Accept > 

> Close 

Iz – изгибный момент инерции; nu – коэффициент Пуассона для металлов. 

 

2 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close  

3 

Два набора реальных констант: 

Сечение площадью A: 

C_P  > R,1,A,Iz,l/10 >  

Сечение площадью 2∙A: 

C_P  > R,2,2*A,Iz,l/5 >  

“l/...” – высота поперечного сечения; формальная величина, использоваться не 

будет, но задать каким-либо положительным числом нужно. 

Посмотрим таблицу реальных констант: 

M_M> Preprocessor > Real Constants > Add/Edit/Delete > Close 
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№ Действие Результат 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK > 

Закрываем окно«Deine Material Model Behavior».  

5 

Координата X точек стержня: 

Определяемся с положением точек относительно глобальной декартовой системы 

координат. Начало отсчёта поместим, например, на левый край стержня, так 

привычнее. 

 

 

Рис.2 

Конечноэлементная модель 

6 

Узлы 1,2 и 3 в точках O, B и C: 

M_M> Preprocessor> Mоdeling> Create> Nodes> In Active CS > 

NODE пишем 1  

X,Y,Z пишем 0,0,0 > Apply > 

NODE пишем 2 

X,Y,Z пишем l,0,0 > Apply > 
NODE пишем 3 

X,Y,Z пишем 2*l,0,0 
> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

Справа от рабочего поля нажимаем кнопку Fit . 

Номер узла 1 сливается со значком глобальной системы координат. 

 

l 

B C 
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y 
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№ Действие Результат 

7 

Скрываем оси системы координат: 

U_M> PlotCtrls> Window Controls> Window Options> 

[/Triad] установить “Not Shown” 

> OK 

 

8 

Первый участок: 

Свойства балочного конечного элемента, имитирующего стержень площалью 

поперечного сечения A: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Elem Attributes > 

[TYPE]установить “1 BEAM3” 

[MAT ]установить “1” 

[REAL]установить “1” 

> OK 

Протягиваем конечный элемент: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

1 и 2 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

9 

Второй участок: 

Свойства балочного конечного элемента, имитирующего стержень площалью 

поперечного сечения 2A: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Elem Attributes > 

[TYPE]установить “1 BEAM3” 

[MAT ]установить “1” 

[REAL]установить “2” 

> OK 

Протягиваем конечный элемент: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

2 и 3 

> OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

 

10 

Заделки: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Displacement > On Nodes > 

Левой кнопкой мыши нажать на 1 и 3 узлы 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
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№ Действие Результат 

11 

Проверяем, верно ли заданы элементам реальные константы: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Real const num”; 

> OK 

Кажется, будто ничего не изменилось. На самом деле участки 

нумеруются уже не номерами конечных элементов, а номерами 

своих реальных констант. Видим на левом участке номер набора 

реальных констант “1” (это площадь A поперечного сечения), 

на правом участке номер набора реальных констант “2” (это 

площадь 2A поперечного сечения). 

Всё верно 

Возвращаемся к нумерации элементов их номерами: 

U_M > PlotCtrls > Numbering > 

Установить Elem на “Element numbers”; 

> OK 

 

 

 

 

12 

Внешняя сила: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Force/Moment > On nodes > 

Левой кнопкой мыши нажимаем на узел 2 

> OK > 

Lab установить “FX” 

VALUE пишем 3*F 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

Расчёт 

13 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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№ Действие Результат 

Просмотр результатов 

14 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

> OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение: U_M > Plot > Elements 

В рабочем поле видим следующее: - Красным цветом начерчена внешняя сила; 

- Малиновым цветом начерчены реактивные силы  

Реакции в заделках совпадают с результатами аналитического расчёта, 

показанными на рис. 1а. (числа, выделенные синим цветом). Минус означает 

направление вектора против оси X. 
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№ Действие Результат 

15 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

16 

Составление эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “1” 

> Apply > 

“By sequence num”, “SMISC,”, “7” 

> OK > 

> Close 

         

 

17 

Прорисовка  эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res >  

LabI установить “SMIS1” 

LabJ установить “SMIS7” 

> OK  

Получаем тот же результат, что и на рис. 1б. (числа, выделенные синим цветом). 

Видим эпюру, состоящую из двух прямоугольников. Высоту каждого можно 

определить по его цвету: левый прямоугольник высотой +1, правый прямоугольник 

высотой -2. 
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№ Действие Результат 

18 

Составление эпюры осевого напряжения: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LS,”, “1” 

> Apply >  

“By sequence num”, “LS,”, “4” 

> OK > 

> Close 

 

19 

Прорисовка эпюры осевого напряжения: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “LS1” 

LabJ установить “LS4” 

> OK  

Получаем тот же результат, что и на рис. 1в. (числа, выделенные на рис. 1в. синим 

цветом). 
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№ Действие Результат 

20 

Составление эпюры линейной осевой деформации: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LEPEL,”, “1” 

> Apply >  

“By sequence num”, “LEPEL,”, “4” 

> OK > 

> Close 

 

21 

Прорисовка эпюры линейной осевой деформации: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “LEPE1” 

LabJ установить “LEPE4” 

> OK  

Получаем тот же результат, что и на рис. 1г. (только числа, выделенные на рис. 1г. 

синим цветом). 
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№ Действие Результат 

22 

Осевые перемещения сечений стержня (таблица): 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > X-Component of displacement 

> OK 

Получаем окно “PRNSOL Command” с табличкой, где NODE – номер узла 

конечноэлементной модели, а UX – его перемещение по горизонтали. 

На этом можно было бы урок и закончить. Интересно, однако, прорисовать 

полученные значения в виде эпюры. Этому будут посвящены последующие два 

действия данной инструкции.  
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№ Действие Результат 

23 

Осевые перемещения узлов стержня (подготовка эпюры): 

Создаём массив-таблицу с названием, например, wtable : 

U_M > Parameters > Array Parameters > Define/Edit > 

 

 

 

 

> Add >  

 

Par=”wtable” 

Type=”Table” 

I,J,K = 3,2,1 

 

 

> OK > 

 

 

 

 

> Edit > 

Нумеруем столбцы и строки массива. 

Заполняем массив вручную. 

Первый столбец – координаты (по 

возрастанию) узлов, то есть координаты 

узлов 1
 го

, 2
го

 и 3
го

 (рис.2). Второй 

столбец - перемещения UX узлов (см. 

результат действия №22). 

> File > Apply/Quit > Close 
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№ Действие Результат 

24 

Осевые перемещения сечений стержня (прорисовка эпюры): 

Параметры, необходимые для построения эпюры: по 

горизонтальной оси будет откладываться первый столбец 

массива, по оси ординат – второй столбец массива. 

U_M > Parameters > Scalar Parameters… > 

XN=1 > Accept > YN=2 > Accept > Close 

Сетка будет на обеих осях эпюры: 

U_M > PlotCtrls > Style > Graphs > Modify Grid > 

[/GRID] установить “X and Y lines”  

> OK 

Горизонтальную ось подписываем “L”, вертикальную ось подписываем “w”, 

интервал по горизонтальной оси устанавливаем от левого конца стержня до 

правого (0…2* l), а интервал по вертикальной оси таким, чтобы поместилась 

эпюра (0…1*F* l/E/A), см. рис. 1д.: 

U_M > PlotCtrls > Style > Graphs > Modify Axes > 

 [/AXLAB] X-axis label пишем L  

 [/AXLAB] Y-axis label пишем w  

[/XRANGE] установить “Specified range”  

XMIN,XMAX установить “0” и “2*l” 

 [/YRANGE] установить “Specified range”  

YMIN,YMAX установить “0” и “1*F* l/E/A” 

> OK 

Прорисовываем эпюру: 

U_M > Plot > Array Parameters  

ParX установить “wtable(1,XN)”  

ParY установить “wtable(1,YN)”  

> OK 

 

 

Получаем ту же самую эпюру, которая изображёна на 

рис. 1д. 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются файлы с 

расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, “.mntr”,  “.rst” и 

”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 

 

 

 

 


